Production site login issue
Incident Report for Uptime monitor
Resolved
This incident has been resolved.
Posted Mar 25, 2021 - 15:09 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2021 - 13:50 EDT
Investigating
Some of the Production users may experience issues logging-in to the portal. We're investigating this problem.
Posted Mar 25, 2021 - 13:49 EDT
This incident affected: PitchAI (Production).